Libraries…

I sure wish my local library would install Mozilla 1.0.x or at least Netscape 7.0. Last time I tried raising the issue (at least six months ago), they weren’t too enthusiastic about the idea. When I first broached it well over a year ago, they mentioned possible issues with security (yeah, right, like IE is secure and Mozilla isn’t).
Oh, well. At least I got to sign a copy of my book over here at the JFK library. The library system’s website is http://snap.lib.ca.us/.